Strex Connect Notification

Incident Report for Strex

Resolved

ISSUE: Please be aware that there is currently a disturbance towards ICE in Norway. - RESOLVED
START: 2026-05-08 07:40 CEST
END: 2026-05-08 10:22 CEST
STATUS: MT (Mobile Terminated) messages error increase, and delivery reports (DLRs) may be delayed.
CAUSE: Unknown at this point. Awaiting root cause analysis from ice
Posted May 08, 2026 - 12:13 CEST

Investigating

ISSUE: Please be aware that there is currently a disturbance towards ICE in Norway.
START: 2026-05-08 07:40 CEST
END:
STATUS: MT (Mobile Terminated) messages error increase, and delivery reports (DLRs) may be delayed.
CAUSE:
Posted May 08, 2026 - 11:26 CEST
This incident affected: Strex Connect.