Strex Connect Notification - Delivery Issue Denmark - Nuuday

Incident Report for Strex

Resolved

ISSUE: Delayed MTs and MOs, missing DLRs and late DLRs - RESOLVED
START: May 19, 16:46
END: May 19, 17:44
STATUS: Resolved
CAUSE: Unknown
Posted May 19, 2025 - 19:23 CEST

Investigating

ISSUE: Delayed MTs and MOs, missing DLRs and late DLRs
START: May 19, 16:46
END:
STATUS: Investigating
CAUSE: Unknown
Posted May 19, 2025 - 17:13 CEST
This incident affected: Strex Connect.